Congrats to our New President Anguss!!
Remember to like us on Facebook!! - https://www.facebook.com/skylinesdownunder

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mantis

Pages: [1] 2 3 ... 13
1
General Performance / Re: C33 Tacho Issue
« on: February 27, 2016, 05:33:23 PM »
check the contacts haven't folded over on the back of the cluster, its usually only a plastic sheet and all it would take is one of the contacts to be dirty or folded and not contacting.

Also are both the Tachos from a twin cam model? The RB20E rev counter wont work on an RB20DE / RB25DE / RB20DET without a resistor being soldered in line

The facelift one I tried is probably from a DE(T), but when I tried the original again it didn't work - maybe I accidentally broke or damaged a wire on the back when changing them? Worth a look though, cheers!

2
General Performance / C33 Tacho Issue
« on: January 25, 2016, 02:36:19 PM »
Been a while since I've posted, decided to come back to hopefully find a source to this issue I encountered.

I bought a facelift manual cluster as I like the font on them, then found it isn't a straight swap over. I pulled the gauges out of the FL cluster and put them into the PFL one and left the fuel gauge til last, finding that it won't work. I left the PFL on it and put the FL cluster in, everything worked fine. I decided I would just stick with the PFL one instead of having FL gauges apart from the fuel one, put the original tacho back in and boom, not working. Replaced it with the FL one thinking I just f'd the PFL one and that one stopped working as well.

Any help? I hate electrical issues!  :'(

3
Maintenance & Car Care / Re: Clutch disengagement issues.
« on: November 05, 2015, 11:05:50 PM »
adjust the pedal

Have already played around with it but I'll let him know, we think the threaded rod from the master cyl may be too short to suit an S14 as it's like 3 threads from the end and it's still playing up how it is.

4
Maintenance & Car Care / Clutch disengagement issues.
« on: November 05, 2015, 05:46:44 PM »
Hey lads,

I'm having a bit of trouble trying to diagnose the issue my mate's having with his freshly converted S14. The issue is that the slave rod on the slave cylinder isn't protruding out far enough when the clutch pedal is depressed in order to move the release bearing enough to fully disengage the clutch, thus effectively having zero clutch. The pedal feels weird, it's not springing back fully and there's about an inch and a half of play where it does zero and within an inch from the floor it starts to have pressure. I probably just explained that like crap so in short, the clutch pedal only seems to have pressure about an inch from the floor, similar to how a heavy duty clutch feels, however the rest of the clutch pedal travel is like it's not even connected to anything.

At first I thought it might just need a bleed, which I told him to do and came out and helped him after he said he's bled it several times and no results. A bit of air came out when I helped him bleed it and the point of travel in the pedal where it moved the slave rod became stiffer, but it still had mountains of play left and was unchanged after bleeding both master and slave.

My current thoughts are the master cylinder has f**ked out, but I'm not that experienced with clutches. Any advice?

5
General Performance / Re: gearbox numbers
« on: September 26, 2015, 12:34:50 AM »
Accoring to my workshop manuals for R33 and R34:

Turbo cars have FS5R30A gearboxes
Whereas DE cars have FS5W71C

And according to the internet (no idea how reliable this is:

"for r31/r32/a31/z31 rb20 boxes, RP71C is the model and next to that is either #1 or #2 which denote either single or double syncros, generally double syncros are only in the turbo variants... the ribs on the gearbox casings I have found don't always match if its a turbo or not as I've pulled a few ribbed boxes from N/A vl commodores and they look identical to an import turbo box, but they arent the same."
I know of a guy who was doing exactley that to a lot of local guys he had tonnes of vl commodores. and was selling the gearboxs as rb20det ones when they wernt actually but looked the same apparently.

Don't quote me on this, but I'm sure the reason behind it is that the RP71C #1 gearboxes stamped with a Kangaroo (The gearbox I've put in my C33) were the 20DET boxes used in Australian-assembled Skylines with larger synchos, which were also used in 30E VL Commodores.

6
Naturally Aspirated / Utilizing N/A to it's full potential.
« on: September 15, 2015, 11:27:25 PM »
Hey forums;

Been doing a lot of research lately on how to get the most power out of an N/A RB engine. I'm wanting to go down a different path from typical turbos and have a crack at making a fairly quick N/A RB. I recently started to lose faith in decent power figures from N/As, until I read up on Skylines Australia that someone from NZ was running an RB30DE with 380HP at the rear wheels. I've been having a float for about 2 weeks now, dabbling onto sites and trying to pick information out that's useful but so far nothing but other people's power figures without lists of modifications or people telling them to just go DET.

I've bought a stripped 25DE head (with all the pieces, just disassembled) which is the first step towards the 30DE, but I'm hoping to pick the brains of those in my own backyard at what can really make a non-turbo scream. So far, I'm pretty set on getting the head ported and polished, hoping to get some numbers through that, and buying torque-happy cams is a definite on the list, though still need to research for the best option. This is an open thread, and my ideas are open to criticism, I'm hoping to get the most out of this 30DE so let all the knowledge flow on how to best milk an N/A. If the overall numbers don't meet what I'm expecting/hoping for, I'll just settle for a DET. I'd thought about building the engine to handle up to 10,000RPM (given it's even going to make power up to this point) and thought I'd give the team at R.I.P.S. a buzz to get their opinion on it. I was given a note to avoid skimming the head and rather replace the conrods with ARGO/Nitto Steel I beam rods, and that in order to continue making power past 6,000RPM was reliant on head work. I also managed to find a very informative article on Skyline's Australia which goes in-depth on how to get the most out of an N/A RB, which included things like cam regrinding etc. Source link posted below. By the looks of this article, the recommended path for high-power output is;

- Port and Polish
- Increase CR either via head skim, block skim, or different pistons.
- Reduce as much restrictions for air-flow and exhaust-flow as possible.
- Increase valve size.
- Camshaft regrinding.
Source link: http://www.sau.com.au/forums/topic/194033-how-to-get-more-power-from-a-naturally-aspirated-na-engine/

Feel free to share your knowledge on the topic below, will add all useful information to this post to help others in the future.


7
Picture Post / Re: Redbush's C34
« on: September 15, 2015, 06:35:28 PM »
Looks dope man, welcome aboard the C-Chassis train  ;D

8
Naturally Aspirated / Re: Port and Polish - Any good services in AKL?
« on: September 11, 2015, 08:24:47 PM »
I was referred to Takanini Cylinder Heads, apparently they're good with what they do. I've sent an email to the two you've provided westy, just waiting for a reply on a quote now :)

9
How To's | Tutorials | D.I.Y / Re: Part number
« on: September 11, 2015, 08:24:00 PM »
When it's in the car, it'll be on the passenger side of the gearbox (left hand.) Could be wrong but that's from memory, should be readable if it was jacked up and you had a crawl underneath it :)

10
Naturally Aspirated / Port and Polish - Any good services in AKL?
« on: September 10, 2015, 11:13:09 PM »
Hey guys,

Finally getting the 30DE build underway, first step is to get the head ported and polished. Does anyone know a good company or guy to go through for this? Price is no object, if I don't have the cash now I'll wait til I do. Prefer great workmanship over price, and in Auckland :)

Cheers!

11
Audio, Security and Electrical / Re: Recommended factory looking headunit
« on: September 02, 2015, 04:24:30 PM »
Part number is KW-V21BT, link to the JVC site is http://jvc.net/nz/car_audio/audio_visual_receivers/kw-v21bt/index.html.

Also, are you located in South Auckland by any chance? If you are, I'm working at a local Repco and have no issues giving a discount off retail prices if you're around the area. :)

12
Audio, Security and Electrical / Re: Recommended factory looking headunit
« on: September 01, 2015, 06:01:42 PM »
My mate recently put one in his Subaru which I wired up for him, JVC KW-V210BT or something like that. Looks real nice, would be even better if he could figure out how to put custom backgrounds on it but he's a little challenged when it comes to technology and cars. Overall the features are quite nice on it from what I've seen :)

13
I don't really know anything that could match factory, but I would suggest going with something that looks nice like a touch screen one, thinking of putting one into my C33 soon. :)

14
Off-Topic / Re: Passing the theory test
« on: August 26, 2015, 08:58:53 AM »
Can't remember which site it was, been a while since I've done the theory but they were exactly the same as the theory test. Might be that one, not sure unfortunately.

15
Had a custom exhaust spacer machined up, got my piping and bought my gaskets ready for the straight pipe to be made up, a more successful and constructive weekend on the car :)

Pages: [1] 2 3 ... 13