Congrats to our New President Anguss!!
Remember to like us on Facebook!! - https://www.facebook.com/skylinesdownunder

Author Topic: R32 Brake lights not working  (Read 2412 times)

Tomy255

  • RB26DETT
  • *****
  • Posts: 502
    • View Profile
R32 Brake lights not working
« on: December 20, 2013, 06:40:12 PM »
Was getting my car ready for wof this afternoon and noticed the brake lights dont work. They light up fine when lights are on, but dont do anything when brake pedal is pushed.

Did some searching and checked the fuse, doesnt seem to be the problem as when its out the dash lights dont work but when its in they do. High stop also wont work with the in car wiring but works fine off a battery. Any ideas? ideally want to get them working asap as its fairly unsafe! cheers

Tomy255

  • RB26DETT
  • *****
  • Posts: 502
    • View Profile
R32 Brake lights not working
« Reply #1 on: December 20, 2013, 07:38:03 PM »
Note: my boost gauge lights werent working (spliced into the ciggarette lighter wiring) and it has happened since i fiddled with the gauge until the lights worked again

BADHAB|T

  • RB26DETT
  • *****
  • Posts: 4843
    • View Profile
R32 Brake lights not working
« Reply #2 on: December 20, 2013, 07:47:34 PM »
It's probably a faulty switch at the top of your brake pedal :)

Tomy255

  • RB26DETT
  • *****
  • Posts: 502
    • View Profile
R32 Brake lights not working
« Reply #3 on: December 20, 2013, 07:58:52 PM »
Any way i could confirm its faulty with a multi meter or something (i am noob with electrics)

Also theres this wire going from the right hand side tail light and goes into the cabin behind the back seat but isnt connected to anything?


BADHAB|T

  • RB26DETT
  • *****
  • Posts: 4843
    • View Profile
R32 Brake lights not working
« Reply #4 on: December 20, 2013, 08:42:55 PM »
Yeah... test the switch to make sure there is 12v either side of it when the pedal is pushed. If there isn't, you've found the problem. It may even just be a sticky switch!

It's impossible to say what circuit that wire is connected to, but there are brake, tail and indicator circuits there. It's serving absolutely no purpose and is a potential short if the other end touches bare metal.... if it were my car I'd remove the wire. Hold the red thing tight and the wire will probably just pull out... those connectors are utter sh1te!

Tomy255

  • RB26DETT
  • *****
  • Posts: 502
    • View Profile
R32 Brake lights not working
« Reply #5 on: December 22, 2013, 11:59:05 AM »
Replaced the switch and still doesnt work :/ also tried the factory switch in my mums car (Nissan Prairie Joy lol) and its a direct swap and the factory one still works soooo im lost, must be a wire down the line might just take it to an auto sparky

fast4motion

  • RB20DET
  • ***
  • Posts: 110
    • View Profile
R32 Brake lights not working
« Reply #6 on: December 22, 2013, 01:02:17 PM »
Quote from: Tomy255;623156
Did some searching and checked the fuse, doesnt seem to be the problem as when its out the dash lights dont work but when its in they do.


Dash lights usually work off the tail light fuse, which is separate to the brake light fuse. So I suspect you checked/removed the wrong fuse.

Have you checked to see if you have 12V at the brake switch?

Tomy255

  • RB26DETT
  • *****
  • Posts: 502
    • View Profile
R32 Brake lights not working
« Reply #7 on: December 23, 2013, 07:28:18 PM »
Wow i read the translation wrong, you're
right i got the wrong fuse! And it was that that was the issue -.- cheers fast4motion