Congrats to our New President Anguss!!
Remember to like us on Facebook!! - https://www.facebook.com/skylinesdownunder

Author Topic: Car's exhast poping and back firing at high RPMs  (Read 2352 times)

ph1

  • Guest
Car's exhast poping and back firing at high RPMs
« on: June 10, 2001, 03:36:24 AM »
BABY R
Registered User
(6/8/01 11:08:00 pm)
Reply
  Car's exhast poping and back firing at high RPMs
--------------------------------------------------------------------------------
 Hi all, got my car back today with the new clutch. But noticed on the way back, when i rev up the car harder, say beyond 5000RPMs, the exhaust just makes a whole lot of poping noises in a series..ppoppopopoopooppoopopo, sounds like hit the rev limiter... whats the deal with it? Plugs? Timing?
Boost it up and rev to the red!
BABY R
 
forsteen
Registered User
(6/8/01 11:23:51 pm)
Reply  Re: Car's exhast poping and back firing at high RPMs
--------------------------------------------------------------------------------
 When I was in neutral and reved it past 5000 to 6000 and let it drop it gave a popping noise once in a while. My problem was a cylinder not firing. If you decide to rev the car in neutral does it almost want to stall?

You might want to check all of your plugs to see if they are all connected fully. Just my guess.
Forsteen

Hey!! Where are my pants!!??
 
whatsisname  
Registered User
(6/9/01 4:41:32 am)
Reply  Re: Car's exhast poping and back firing at high RPMs
--------------------------------------------------------------------------------
 BABY R,
Sounds like you've gotta' misfire problem mate.
Start with the basics, check the plugs, if there fouled or shot that'll cause it, could be a coil on it's way out but I doubt it, from the way you describe the prob I'd put money on it being a plug or plug gap, octane boost (or too much of it) is good for fouling plugs & then misfiring starts happening.

If your running higher than stock boost I'd recommend a smaller plug gap than factory spec, say 0.8-0.9mm the smaller the gap the lower outright power (only a small difference) but better reliablity of spark & so on.

You haven't recently wound the boost up have you? high rev/high boost misfire is a common thing.
 
WDRacing
Registered User
(6/9/01 6:41:57 am)
Reply  Re: Car's exhast poping and back firing at high RPMs
--------------------------------------------------------------------------------
 I agree with that whatshisname guy...LOL. If your still misfiring I'd get gas from a different place just to make sure before I tore my car apart. Let me know...


WDR
 
R U NUTS  
Registered User
(6/9/01 9:45:04 am)
Reply  Re: Car's exhast poping and back firing at high RPMs
--------------------------------------------------------------------------------
 i remember that ur car got a aftermarket computer.
most aftermarket computer in japan has been tuned to run 100 octane gas, so i think the ignition timing is different. i also agree with the plugs, might wanna check the coils too..
 
BABY R
Registered User
(6/9/01 10:39:50 am)
Reply  PLUGs
--------------------------------------------------------------------------------
 Thanx for all the inputs guys, the car was running fine before, but ever since i came back from the drags and tuned up the boost to 0.8bar by removing the restrictor in the hose and changing the entire clutch assembly, lightened flywheel, pressure plate and clutch plate, the engine revs quite freely but when reached to beyond 5000rpms, a series of poping sounds occured and feels that the car is loosing power... The gas i used is Synergy 8000 from Mobile which is 98 Octane, didn't put in any octane boosters, but i think its the plugs on its way out. Better go change it today so i can be ready tomorrow.!! So whats the plugs coding? NGK PFR7A-II? and regap them to about 0.9mm?