Congrats to our New President Anguss!!
Remember to like us on Facebook!! - https://www.facebook.com/skylinesdownunder

Author Topic: My POS L20E  (Read 3257 times)

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« on: May 11, 2013, 03:31:24 PM »
Had enough! Have tried everything to solve my cars fuelling and cooling issues. Have replaced the coolant temp sensor and thermostat with genuine parts, to no avail. The idle sits between 2 and 2500rpm cold, and 15-1800 when warm. 15 bucks worth of 95 will get roughly 40km round town and the car blows black smoke at full throttle higher in the revs. I have had the AFM apart and it was mint, but I got the contact cleaner onto it anyway, made no difference. Have also cleaned all the plugs and connectors, ran the car with and without an air filter, again negligible difference. Also tried an ET ECU to see if it would make any difference to the idle as it almost seems as though the cold start isn't switching off completely. Are there any other sensors to look at or anything else to adjust? I've had an absolute gutsful of this f*cken bag of sh*t and the money it's costing me, I've lined up the complete driveline from my mate's coupe (possibly the whole car if I.get lucky :D), including an L20ET and disc brake rear but I need to try sort out what I've got in the meantime. Any ideas? Ready to put a brick on the gas pedal and walk away tbh.
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #1 on: May 11, 2013, 03:36:29 PM »
AFM





Thermostat



Forgot to mention, car has what looks like a VK or VL commy radiator wonderfully hori'd up with cable ties and flexi hose. Temp gets to about quarter, then drops cruising at 100 or going downhill.
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

Shrike

  • RB26DETT
  • *****
  • Posts: 1071
    • View Profile
My POS L20E
« Reply #2 on: May 11, 2013, 04:02:25 PM »
rad could be two big and cooling the coolent to much
Quote from: MZ ROLA;555218
Personally i prefer DP

Quote from: Stalk3r;558679
mmmm sausage

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #3 on: May 11, 2013, 04:40:21 PM »
But in theory the thermostat should be closing in that situation.
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

Harley

  • RB26DETT
  • *****
  • Posts: 1651
    • View Profile
    • WD - No bullshit ISP
My POS L20E
« Reply #4 on: May 11, 2013, 05:33:07 PM »
put a carb on it

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #5 on: May 11, 2013, 05:58:44 PM »
Waste of time and money on a 2 litre, if it was an L28 then yeah definitely.
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

StageFumer11

  • RB26DETT
  • *****
  • Posts: 2926
    • View Profile
    • http://
My POS L20E
« Reply #6 on: May 11, 2013, 06:31:10 PM »
hurrmmmmm......... Clean all your pins and plugs on the ecu, and put contact grease on them, Check the plug on the afm for broken wires.

Unplug the cold start valve controller and block off the hoses
1985 R30 Skyline Coupe

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #7 on: May 12, 2013, 07:00:48 AM »
Is that the black canister looking thing under the throttle body? Most of the vacuum lines on my inlet manifold have been cut and blocked off too so I wouldn't know where to start :(
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

project r30

  • RB20E
  • *
  • Posts: 47
    • View Profile
My POS L20E
« Reply #8 on: May 12, 2013, 11:25:42 AM »
i took all of the emission control and cold start off my old l20 and it ran the best it ever did for me,even in cold weather it would start 1st pop.i had nothing on the inlet plenuim at all. have you checked to see if it has a leaking gasket on the intake manifold? this would cause it to idle high.

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #9 on: May 12, 2013, 11:59:01 AM »
Any pics of what you did? Sounds like the go :)

I'll get the engine start out and have a play, could be the go :)

Anyone priced an 02 sensor for one of these?
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #10 on: May 12, 2013, 02:50:12 PM »
Ok, tried the engine start trick, no gasket leak. Have unplugged the 02 sensor and it hasn't made any difference. ****ed with the ignition timing, that wasn't the issue. Blocked off all vacuum ports except the brake booster and FPR, both diaphragms on the inlet manifold are disconnected, car is idling smoother but still around the 1400rpm mark. Took the viscous fan off, car is now getting up to temp but STILL running rich and idle isn't dropping. Will try the ECU connections again soon and as far as I can see AFM wiring is fine.
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #11 on: May 12, 2013, 06:56:59 PM »
Well after pulling the throttle body off and cleaning it all and it's associated gubbins, and putting it back together with no change in results I have come to the conclusion it's f*cked. I have officialy gone insane, see you all down the rabbit hole :D
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

kyteler

  • RB25DET
  • ****
  • Posts: 499
    • View Profile
    • http://blog.retro-classics.co.nz/
My POS L20E
« Reply #12 on: May 12, 2013, 09:56:35 PM »
Mine ran like a rich bag of **** when it had the wrong ECU on it.  That said, I have a million other issues also, so perhaps mine isn't the best example to follow. Hah.
1963 Prince Skyline (S21)| 1973 Nissan Skyline (C110)| 1983 Nissan Skyline (R30)

AGRORB

  • RB26DETT
  • *****
  • Posts: 1634
    • View Profile
My POS L20E
« Reply #13 on: May 13, 2013, 12:50:41 AM »
I've had a.turbo ECU in it, just to see if the idle changed at all. Took it for a drive, more smoke than my old Kenworth, few flames, no balls and many lulz. I don't think it's a computer problem :p
Truck drivers - We go ALL night.

BWARP.NET.NZ | BLOG | FORUM | SHOP

Quote from: ibb&;559471
I\'d drag my dick through a mile of glass just to hear her fart through a CB radio

 
Quote from: nathan1017;591767
giving the knob to sdu.
[SIGPIC][/SIGPIC]

base

  • RB26DETT
  • *****
  • Posts: 522
    • View Profile
My POS L20E
« Reply #14 on: May 13, 2013, 05:43:36 PM »
Hasn't got turbo injectors or something  like dat try a different afm not just cleaning