Congrats to our New President Anguss!!
Remember to like us on Facebook!! - https://www.facebook.com/skylinesdownunder

Author Topic: R34 4 Door Daily/Ongoing project  (Read 4622 times)

patio6

  • RB20E
  • *
  • Posts: 17
    • View Profile
Re: R34 4 Door Daily/Ongoing project
« Reply #15 on: April 05, 2015, 06:41:14 PM »
Yeah mate, factory r33 turbo I was told.

Oh nice, were you able to tune to handle the high comp?

westybob

  • RB26DETT
  • *****
  • Posts: 2990
    • View Profile
Re: R34 4 Door Daily/Ongoing project
« Reply #16 on: April 05, 2015, 07:31:57 PM »
Yeah mate, factory r33 turbo I was told.

Oh nice, were you able to tune to handle the high comp?
The DE neo head has 6.9 lift on the exhaust cam while the DET has 8.7 so that will be a bit of a restriction  - but should still go better than without turbo! Did you get some DET injectors? There was a Nistune chip for sale for a Neo not too long ago on TradeMe.
« Last Edit: April 05, 2015, 07:33:31 PM by westybob »

patio6

  • RB20E
  • *
  • Posts: 17
    • View Profile
Re: R34 4 Door Daily/Ongoing project
« Reply #17 on: April 05, 2015, 08:05:29 PM »
Ok, shouldn't be an issue at the 8 PSI I want to run, but cheers for the info :D. Yeah, have DET injectors and DET ECU but there seems to be some wiring differences, also its running what looks like some sort of j side daughterboard. Had that chip on my watchlist for a couple of months but never got around to it. Im hoping the factory DE ecu will run the DET injectors for now ( theyre not in yet). Don't mind running rich until I get the ECU sorted out and the Nistune in

Aubrey107

  • RB25DET
  • ****
  • Posts: 319
    • View Profile
Re: R34 4 Door Daily/Ongoing project
« Reply #18 on: June 15, 2015, 02:00:02 PM »
Any new updates man? Looking good soo far!

patio6

  • RB20E
  • *
  • Posts: 17
    • View Profile
Re: R34 4 Door Daily/Ongoing project
« Reply #19 on: June 28, 2015, 10:26:41 PM »
The plus t didn't last long. Have just recently bought a 25det neo engine and have thrown it in over the weekend but am having massive wiring issues as it would appear they are not plug and play at all. Unless I've no clue what I'm doing. Have rewired everything that needed it and spliced it also but there seems to be power in the wrong places and tge fuel pump isnt priming, relay not powering up etc. Haven't done much body wise lately but am planning on getting a couple of second hand guards and doing a bit of chopping and playing around with vents and what not as I have a huge thing against Fibreglass haha. Also bought adjustable suspension, castor arms, fuel pump ect. Am looking into getting rid of my wheels and putting factory or gtst wheels on it as I'm growing against the ones on it.